Last Updated about a month ago

Error "module expired"

We regularly implement changes in our modules to improve stability and security. If you haven't updated your PrestaShow modules for a long time, there is a good chance that one of the components used by our modules (IonCube) may expire, and your store may suddenly get an error like "Error: module expired" and the module will stop working.

Using old software versions makes your store prone to errors. This goes for all the components the store uses: modules, PHP, MySQL and the PrestaShop engine itself.

Our modules are built from two key components:

  1. Module skeleton- responsible for licensing, stability, compatibility and security of the module.
  2. The logic part of the module - responsible for the functions of the module and the functioning of the module.
We always provide skeleton updates for our modules for free, no matter what version of the module you have access to.

Even if you do not have access to the latest version of the module, downloading a "fresh" module package from your PrestaShow account or performing a 1-click update on the module will make the module update its skeleton to the latest available version.

How to find out if the problem applies to your store?

Make sure your store's PrestaShow module directories include a .license.txt file, such as /modules/pshowblog/.license.txt:

  • If you found this file, it means that you are using a stable version of the module framework and actions are not necessary, although the module is always worth updating.
  • The absence of this file means that you need to update the module - failure to update may cause errors in the operation of the module and/or the store.

How to update PrestaShow module?

If you can get into the configuration of the module - perform a 1-click update on your store:

  1. Make a backup copy of the folder with the module and the database (this is not necessary, but recommended)
  2. Log in to the administration panel of your store and go to the module configuration page
  3. Click on the module version at the top of the page or on the message about the availability of a new version
  4. Click on the "Update" or "Force update" button.
If the above method does not work, do the update manually:

  1. Make a backup of the folder with the module and the database (not necessary, but recommended)
  2. Go to My Account on PrestaShow
  3. Select your domain and download the module
  4. Upgrade via FTP the module files
If you have questions or concerns about module updates, our support team on HelpDesk is ready to assist you.

Please Wait!

Please wait... it will take a second!

Kliknij by skopiować