Frequently Asked Questions

Last Updated 6 months ago

The minimum system requirements of all modules available in our store will soon change.

New system requirements:

* PHP version 7.1 or higher
* installed and active ionCube extension

Why do we increase the requirements?

PHP in versions below 7.2 no longer has active support from developers - e.g. they do not provide security patches. For this reason, using older versions is not safe and update is highly recommended. We decided to introduce version 7.1 because many shops are not ready for such a large update yet. However, it's possible that we'll be upgrading to PHP 7.2 in the coming months. PHP support status is available at https://www.php.net/supported-versions.php

For the security of your stores we also decided to implement ionCube. This PHP extension, among other things, prevents viruses from adding malicious code to files. This will protect you from data leakage from the store database.


Does the shop meet the requirements?

Checking if the shop meets the new system requirements is very easy and takes up to several minutes.

This is what you need to do:
1. Connect to the server (where your shop is running) via FTP - you can use the free FileZilla
2 program for this purpose. Go to the main PrestaShop directory - this is where you can find controllers, classes, override.
3. Create a new file named prestashow-test.php with the content:
echo ((version_compare(phpversion(), '7.1.0', '>=')) 
  ? 'Very well, you have the required PHP version. " : 'Unfortunately, the PHP version is old. ') 
. ((function_exists('ioncube_file_is_encoded')) ? 'Very well, you have ionCube installed. " : 'Unfortunately, no ionCube. ');
4. Open the PHP file through your web browser by going to (replace the domain with yours):
http://example.com/prestashow-test.php
5. Delete the file prestashow-test.php

How to update server?

The PHP version can usually be changed from the hosting panel. However, if this is not possible, you have to do it manually. We will not give instructions as this depends on many factors and it is best to find someone to help you do this. Information about how to install and activate the ionCube extension can be found at the address: https://www.ioncube.com/loaders.php

When will new requirements be introduced?

The activation of higher system requirements is planned for the coming weeks. However, we recommend that you prepare your server now. When higher requirements are activated, we will post a message informing you about this in your shop's modules.

Until then you can still update the modules as before.

Please Wait!

Please wait... it will take a second!